Skip to content

Commit

Permalink
new package: kdenlive
Browse files Browse the repository at this point in the history
  • Loading branch information
knyipab committed Oct 4, 2024
1 parent 51b4ef9 commit 388f37e
Showing 1 changed file with 42 additions and 0 deletions.
42 changes: 42 additions & 0 deletions x11-packages/kdenlive/build.sh
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
TERMUX_PKG_HOMEPAGE='https://apps.kde.org/kdenlive/'
TERMUX_PKG_DESCRIPTION='A non-linear video editor for Linux using the MLT video framework'
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=24.08.1
TERMUX_PKG_SRCURL=https://download.kde.org/stable/release-service/${TERMUX_PKG_VERSION}/src/kdenlive-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=55b42af545304ec26bf20b4e9e79e89e91d61481fbbb93a5df7c74e86fbae142
TERMUX_PKG_DEPENDS="frei0r-plugins, kf6-karchive, kf6-kbookmarks, kf6-kcodecs, kf6-kcolorscheme, kf6-kcompletion, kf6-kconfig, kf6-kconfigwidgets, kf6-kcoreaddons, kf6-kdbusaddons, kf6-kfilemetadata, kf6-kguiaddons, kf6-ki18n, kf6-kiconthemes, kf6-kio, kf6-kitemviews, kf6-knewstuff, kf6-knotifications, kf6-knotifyconfig, kf6-ktextwidgets, kf6-kwidgetsaddons, kf6-kxmlgui, kf6-purpose, kf6-qqc2-desktop-style, kf6-solid, mlt, qt6-qtbase, qt6-qtdeclarative, qt6-qtmultimedia, qt6-qtnetworkauth, qt6-qtsvg, shared-mime-info"
TERMUX_PKG_BUILD_DEPENDS="extra-cmake-modules, kf6-kconfig-cross, qt6-qttools"
# TERMUX_PKG_RECOMMENDS="bigsh0t, dvgrab, ffmpeg, kf6-kimageformats, mediainfo, noise-suppression-for-voice, opencv, opentimelineio, plasma-desktop, python-openai-whisper"
TERMUX_PKG_AUTO_UPDATE=true
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-DCMAKE_SYSTEM_NAME=Linux
"

termux_step_pre_configure() {
# patch to run config_compiler_kf6 in compile time
export LD_LIBRARY_PATH="$TERMUX_PREFIX/opt/qt6/cross/lib"
sed -e 's|_IMPORT_PREFIX "'$TERMUX_PREFIX'"|_IMPORT_PREFIX "'$TERMUX_PREFIX'/opt/kf6/cross"|' -i $TERMUX_PREFIX/lib/cmake/KF6Config/KF6ConfigCompilerTargets.cmake
sed -e 's|'$TERMUX_PREFIX'/lib/libexec/kf6/kconfig_compiler_kf6|'$TERMUX_PREFIX'/opt/kf6/cross/lib/libexec/kf6/kconfig_compiler_kf6|' -i $TERMUX_PREFIX/lib/cmake/KF6Config/KF6ConfigCompilerTargets-release.cmake
# ERROR: MIME cache found in package. Please disable `update-mime-database`
sed -e 's|update_xdg_mimetypes(|# update_xdg_mimetypes(|' -i data/CMakeLists.txt
}

termux_step_post_make_install() {
unset LD_LIBRARY_PATH
# dirty remove .cmake files to prevent being installed
rm $TERMUX_PREFIX/lib/cmake/KF6Config/KF6ConfigCompilerTargets.cmake
rm $TERMUX_PREFIX/lib/cmake/KF6Config/KF6ConfigCompilerTargets-release.cmake
}

termux_step_create_debscripts() {
cat <<- EOF > ./postinst
#!$TERMUX_PREFIX/bin/sh
update-mime-database "${TERMUX_PREFIX}/share/mime"
EOF

cat <<- EOF > ./prerm
#!$TERMUX_PREFIX/bin/sh
update-mime-database "${TERMUX_PREFIX}/share/mime"
EOF
}

0 comments on commit 388f37e

Please sign in to comment.